Notification of Planned Supplier Maintenance - ID3global Netherlands Identity (0254)
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was between 07:55 – 08:35 BST 30/03/2020
Posted Mar 30, 2020 - 09:37 BST
Investigating
This notification is to inform you of planned maintenance work being carried out by our supplier.

*Can we describe the maintenance*

During the dates/times specified, the service will be unavailable and failures will occur for the below item checks.
Posted Mar 30, 2020 - 08:48 BST
This incident affected: GBG ID3global (Netherlands Identity (0254)).