Service Disruption - ID3 China Population item check 0309
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.
Posted Sep 17, 2019 - 08:44 BST
Update
We are still working with our supplier to resolve this issue and will provide a further update as soon as we have a resolution on this issue.
Posted Sep 16, 2019 - 16:45 BST
Update
We are continuing to investigate this issue with our data supplier and are working hard to resolve this.
Posted Sep 16, 2019 - 11:31 BST
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Sep 16, 2019 - 08:21 BST