Capture Service Fixes
Incident Report for GBG
Postmortem

On Thursday 11 February 2021 at 1040 GMT, customers using our Capture solution experienced an error where USPS address information was appending an incorrect +4 range.

Our technical support teams took action to identify the root cause and restore service; service was confirmed restored at 2130 GMT. We would like to apologise to all customers for the loss of this service function and the inconvenience caused during this time. We’re pleased to assure you that the incident is fully resolved and steps are in place to mitigate a recurrence.

The incident occurred due to a scheduled release which included a fix for the +4 on a specific USPS address ZIP code, however the change impacted the +4 on a larger quantity of USPS addresses. To restore service the change was fully rolled back. Our Product and Development teams are reviewing their technical peer and test criteria to ensure there is no re-occurrence when implementing the original targeted code fix.

Once again, apologies for any impact on your operations during this time. A Post Incident Review held with GBG technical teams and senior stakeholders will ensure remediation is fully supported and that future improvements are identified to ensure continued high availability of service that you expect from GBG.

Posted Feb 12, 2021 - 20:14 GMT

Resolved
Issue has now be resolved across all data centres.

All customers should now be able to retrieve Zip+4 results.
Posted Feb 12, 2021 - 10:12 GMT
Monitoring
We're pleased to inform you that the Capture service issue has now been resolved for US customers. The issue was only affecting zip+4 results for some US addresses. US customers, using api.addressy.com endpoint should now be able to see expected Zip+4 results.

Customers using service.postcodeanywhere.co.uk endpoint to search for a US address would see this change implemented tomorrow AM GMT.
Posted Feb 11, 2021 - 22:10 GMT
Identified
The impact is only for US address: Zip+4 results, and we have identified a fix which is being rolled out.
Posted Feb 11, 2021 - 21:39 GMT
Update
We are continuing to investigate this issue.
Posted Feb 11, 2021 - 21:13 GMT
Investigating
We are investigating an issue affecting our Capture data service. This primarily affects some US addresses. Our Incident Team is working to identify the root cause and implement a solution as a priority. We hope to advise you within the next hour with updates.
Posted Feb 11, 2021 - 21:11 GMT
This incident affected: Loqate (Capture V3).