Service Disruption - 0357 - Australia Marketing
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported earlier is due to on-going maintenance and will continue to 16:00 BST
Posted May 24, 2022 - 09:17 BST
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted May 24, 2022 - 09:10 BST
This incident affected: GBG ID3global (Australia Marketing (0357)).