Service Disruption - ID3 Malaysia Financial (0354)
Incident Report for GBG
Resolved
This incident has been resolved.
Posted May 15, 2022 - 19:28 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 15, 2022 - 08:49 BST
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted May 14, 2022 - 16:18 BST
This incident affected: GBG ID3global (Malaysia Financial (0354)).