Service Incident for Loqate - Utilities Register - Electricity
Incident Report for GBG
Resolved
We're pleased to inform you that the service disruption has now been resolved and users should be able to use the system as normal.

The incident duration was between 09:39 GMT – 10:41 GMT 14/03/24

To customers that have been affected by this issue, we would again like to apologise.
Posted Mar 14, 2024 - 11:06 GMT
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Mar 14, 2024 - 09:59 GMT
This incident affected: Loqate (Utilities Register - Electricity).